# CVE-2026-105745: Docling: Plugin entry points are imported before the allow_external_plugins check

> Attackers can execute arbitrary code via malicious installed packages because Docling imports plugin entry points before checking the external plugin allowlist.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-9jxx-vjrv-h2rq, PYSEC-2026-4192, PYSEC-2026-4210

## What is CVE-2026-105745?

CVE-2026-105745 is a medium-severity code injection vulnerability in docling-project docling, published on 5 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.27.0 until 2.131.0, Docling plugin factories in docling/models/factories/base_factory.py call load_setuptools_entrypoints() before applying the allow_external_plugins setting, so every module registered in the Docling entry-point group is imported even when external plugins are disabled. An installed third-party or compromised package can therefore execute import-time code when Docling starts, while the subsequent namespace filter misleadingly reports that the plugin was not loaded. This issue is fixed in 2.131.0.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-696 (Incorrect Behavior Order)

## Which versions are affected by CVE-2026-105745?

6 open source packages ship an affected version, including docling and docling-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.27.0 | 2.131.0 |
| `docling` | PyPI | From 2.27.0 | 2.131.0 |
| `docling` | PyPI | From 2.27.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |

Products: Docling Docling.

## How do I fix CVE-2026-105745?

Upgrade docling to 2.131.0 or later.

## Is CVE-2026-105745 being exploited?

There is no known exploitation of CVE-2026-105745 in the wild and no public exploit code.

## Other vulnerabilities in docling-project docling

- [CVE-2026-44016](https://insights.sbomify.com/CVE-2026-44016/): Docling: Unsafe Playwright-based HTML Rendering (high 8.2)
- [CVE-2026-105744](https://insights.sbomify.com/CVE-2026-105744/): Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine (high 7.5)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105745 and fix it if it is affected.

What it is: CVE-2026-105745 is a medium-severity code injection vulnerability in docling-project docling, published on 5 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-105745 in the wild and no public exploit code.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.27.0; fixed in 2.131.0
- docling (PyPI): affected from 2.27.0; fixed in 2.131.0
- docling (PyPI): affected from 2.27.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105745/ (Markdown: https://insights.sbomify.com/CVE-2026-105745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105745
- OSV: https://osv.dev/vulnerability/CVE-2026-105745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105745/
Summaries are generated and may contain mistakes; the official description above is the record.
