# CVE-2026-105747: Docling: METS-GBS archive member limit enforced after full member enumeration (memory exhaustion during format detection)

> Attackers can cause memory exhaustion and denial of service by submitting crafted METS-GBS archives to Docling before member limits are enforced.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-3cr3-8m4c-fpxw, PYSEC-2026-4194, PYSEC-2026-4209

## What is CVE-2026-105747?

CVE-2026-105747 is a medium-severity denial of service vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.45.0 until 2.131.0, METS-GBS format detection in docling/datamodel/document.py and the backend in docling/backend/mets_gbs_backend.py call tarfile.TarFile.getmembers() before enforcing the max_member_count limit, causing the full archive member list to be allocated before the limit can stop processing. A small gzip-compressed tar archive with a very large number of empty members can therefore consume memory proportional to the declared member count, including during format detection before the allowed_formats restriction is applied. This issue is a residual weakness in the member-count protection added for CVE-2026-44018. This issue is fixed in 2.131.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-105747?

6 open source packages ship an affected version, including docling and docling-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.45.0 | 2.131.0 |
| `docling` | PyPI | From 2.45.0 | 2.131.0 |
| `docling` | PyPI | From 2.45.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |

Products: Docling Docling.

## How do I fix CVE-2026-105747?

Upgrade docling to 2.131.0 or later.

## Is CVE-2026-105747 being exploited?

There is no known exploitation of CVE-2026-105747 in the wild and no public exploit code.

## Other vulnerabilities in docling-project docling

- [CVE-2026-44016](https://insights.sbomify.com/CVE-2026-44016/): Docling: Unsafe Playwright-based HTML Rendering (high 8.2)
- [CVE-2026-105744](https://insights.sbomify.com/CVE-2026-105744/): Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine (high 7.5)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105747 and fix it if it is affected.

What it is: CVE-2026-105747 is a medium-severity denial of service vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-105747 in the wild and no public exploit code.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.45.0; fixed in 2.131.0
- docling (PyPI): affected from 2.45.0; fixed in 2.131.0
- docling (PyPI): affected from 2.45.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105747/ (Markdown: https://insights.sbomify.com/CVE-2026-105747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105747
- OSV: https://osv.dev/vulnerability/CVE-2026-105747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105747/
Summaries are generated and may contain mistakes; the official description above is the record.
