# CVE-2026-105749: Docling: Unbounded table rowspan/colspan in HTML, JATS, ODS and BoxNote backends causes CPU/memory exhaustion

> Attackers can cause CPU and memory exhaustion in Docling by submitting documents with unbounded table spans, leading to denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-cgc7-9qp3-86m3, PYSEC-2026-4195, PYSEC-2026-4211

## What is CVE-2026-105749?

CVE-2026-105749 is a medium-severity denial of service vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.0.0 until 2.131.0, the HTML, JATS, OpenDocument spreadsheet, and BoxNote backends, including docling/backend/html_backend.py, docling/backend/jats_backend.py, and docling/backend/boxnote_backend.py, accept the rowspan and colspan attribute values without an upper bound and execute loops or allocate a table grid proportional to the declared span. A very small document can therefore cause sustained CPU use or multi-gigabyte memory allocation, and the document_timeout setting does not interrupt the single backend conversion call. Export through the TableData.grid property can further materialize the oversized grid. This issue is fixed in 2.131.0.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-105749?

6 open source packages ship an affected version, including docling and docling-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.0.0 | 2.131.0 |
| `docling` | PyPI | From 2.0.0 | 2.131.0 |
| `docling` | PyPI | From 2.0.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |
| `docling-slim` | PyPI | From 2.92.0 | 2.131.0 |

Products: Docling Docling.

## How do I fix CVE-2026-105749?

Upgrade docling to 2.131.0 or later.

## Is CVE-2026-105749 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105749 exists.

## Other vulnerabilities in docling-project docling

- [CVE-2026-44016](https://insights.sbomify.com/CVE-2026-44016/): Docling: Unsafe Playwright-based HTML Rendering (high 8.2)
- [CVE-2026-105744](https://insights.sbomify.com/CVE-2026-105744/): Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine (high 7.5)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105749 and fix it if it is affected.

What it is: CVE-2026-105749 is a medium-severity denial of service vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105749 exists.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.0.0; fixed in 2.131.0
- docling (PyPI): affected from 2.0.0; fixed in 2.131.0
- docling (PyPI): affected from 2.0.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.131.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105749/ (Markdown: https://insights.sbomify.com/CVE-2026-105749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105749
- OSV: https://osv.dev/vulnerability/CVE-2026-105749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105749/
Summaries are generated and may contain mistakes; the official description above is the record.
