# CVE-2026-105750: Docling: `enable_local_fetch` is not enforced in HTML browser-rendering mode

> Attackers can read local files via crafted HTML when using the browser-rendering mode with local fetch enabled, exposing sensitive data.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-q43m-vhcp-mhvm, PYSEC-2026-4196, PYSEC-2026-4215

## What is CVE-2026-105750?

CVE-2026-105750 is a medium-severity path traversal vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.82.0 until 2.118.1, HTMLBackendOptions(render_page=True) permits file URLs because HTMLDocumentBackend._get_browser_request_block_reason does not enforce the enable_local_fetch setting or confine local requests to the source document directory. Crafted path-backed HTML can embed a readable local text file in a browser-rendered page image when Playwright is installed. Only filesystem Path inputs are affected because stream inputs use an opaque origin, and the default configuration, command-line interface, docling-serve, and non-rendering backends are not affected. This issue is fixed in 2.118.1.

Weakness: CWE-863 (Incorrect Authorization), CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2026-105750?

6 open source packages ship an affected version, including docling and docling-slim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling` | PyPI | From 2.82.0 | 2.118.1 |
| `docling` | PyPI | From 2.82.0 | 2.118.1 |
| `docling` | PyPI | From 2.82.0 | 2.118.1 |
| `docling-slim` | PyPI | From 2.92.0 | 2.118.1 |
| `docling-slim` | PyPI | From 2.92.0 | 2.118.1 |
| `docling-slim` | PyPI | From 2.92.0 | 2.118.1 |

Products: Docling Docling.

## How do I fix CVE-2026-105750?

Upgrade docling to 2.118.1 or later.

## Is CVE-2026-105750 being exploited?

There is no known exploitation of CVE-2026-105750 in the wild and no public exploit code.

## Other vulnerabilities in docling-project docling

- [CVE-2026-44016](https://insights.sbomify.com/CVE-2026-44016/): Docling: Unsafe Playwright-based HTML Rendering (high 8.2)
- [CVE-2026-105744](https://insights.sbomify.com/CVE-2026-105744/): Docling has arbitrary file read/write (and command execution when shell-escape is enabled) when rendering untrusted TikZ with the opt-in Tectonic engine (high 7.5)
- [CVE-2026-44017](https://insights.sbomify.com/CVE-2026-44017/): Docling: Unsafe Zip Extraction in EasyOCR Model Download (high 7.5)
- [CVE-2026-44020](https://insights.sbomify.com/CVE-2026-44020/): Docling: Unsafe XML Entity Expansion in USPTO Patent Backend (high 7.5)
- [CVE-2026-47214](https://insights.sbomify.com/CVE-2026-47214/): Docling: Unsafe URI and Path Handling in HTML Backend (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105750 and fix it if it is affected.

What it is: CVE-2026-105750 is a medium-severity path traversal vulnerability in docling-project docling, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105750 in the wild and no public exploit code.

Affected packages and fixed versions:
- docling (PyPI): affected from 2.82.0; fixed in 2.118.1
- docling (PyPI): affected from 2.82.0; fixed in 2.118.1
- docling (PyPI): affected from 2.82.0; fixed in 2.118.1
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.118.1
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.118.1
- docling-slim (PyPI): affected from 2.92.0; fixed in 2.118.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105750/ (Markdown: https://insights.sbomify.com/CVE-2026-105750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105750
- OSV: https://osv.dev/vulnerability/CVE-2026-105750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105750/
Summaries are generated and may contain mistakes; the official description above is the record.
