# CVE-2026-105752: vLLM: Harmony tool continuations drop `cache_salt` — restoring a cross-tenant prefix-cache membership oracle

> Authenticated tenants can infer victim activity via prefix cache timing, bypassing tenant isolation in vLLM deployments with default prefix caching enabled.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-935w-9g4m-p28p, MINI-cfq3-w5c9-chgv, MINI-j935-7xrw-x32q, MINI-mf8m-h427-m656, PYSEC-2026-4308

## What is CVE-2026-105752?

CVE-2026-105752 is a low-severity vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, Harmony tool continuations submitted through "POST /v1/responses" requests rebuild the next-turn engine input without preserving the cache_salt value, placing the continuation prefix in the global unsalted cache namespace even when the caller enabled salting. On deployments with prefix caching enabled, which is the default, an authenticated tenant who can reconstruct a victim's low-entropy post-tool history can submit the same continuation and use the cached_tokens_per_turn count to determine whether the prefix was previously processed, defeating the intended tenant isolation of salted prefix caching. This issue is fixed in version 0.30.0.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-105752?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.30.0 |
| `vllm` | PyPI | All versions | 0.30.0 |
| `vllm` | PyPI | All versions | 0.30.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-105752?

Upgrade vllm to 0.30.0 or later.

## Is CVE-2026-105752 being exploited?

There is no known exploitation of CVE-2026-105752 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105752 and fix it if it is affected.

What it is: CVE-2026-105752 is a low-severity vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105752 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.30.0
- vllm (PyPI): affected all versions; fixed in 0.30.0
- vllm (PyPI): affected all versions; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105752/ (Markdown: https://insights.sbomify.com/CVE-2026-105752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105752
- OSV: https://osv.dev/vulnerability/CVE-2026-105752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105752/
Summaries are generated and may contain mistakes; the official description above is the record.
