# CVE-2026-105753: vLLM: Mirrored multimodal IPC caches desync after a rejected request — a later request reusing the same media hash trips a receiver assertion in the engine core

> An attacker can cause a denial of service in vLLM by triggering a cache desync that leads to an assertion failure in the engine core.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-ph3r-5jfg-f84f, MINI-9hp5-mqg2-2jvh, MINI-pjjw-fgxc-6223, MINI-q7m6-x689-54r2, PYSEC-2026-4197

## What is CVE-2026-105753?

CVE-2026-105753 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.28.0, the default mirrored multimodal LRU cache can commit a media hash in the frontend sender cache during multimodal rendering and before engine admission, while the engine receiver cache never receives the payload if that request is rejected. A later request reusing the same media hash causes MultiModalProcessorSenderCache to send no payload and MultiModalReceiverCache to reach an assertion with the message "Expected a cached item," producing a shared-service availability failure. This issue is fixed in version 0.28.0.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-105753?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.28.0 |
| `vllm` | PyPI | All versions | 0.28.0 |
| `vllm` | PyPI | All versions | 0.28.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-105753?

Upgrade vllm to 0.28.0 or later.

## Is CVE-2026-105753 being exploited?

There is no known exploitation of CVE-2026-105753 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105753 and fix it if it is affected.

What it is: CVE-2026-105753 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105753 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.28.0
- vllm (PyPI): affected all versions; fixed in 0.28.0
- vllm (PyPI): affected all versions; fixed in 0.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105753/ (Markdown: https://insights.sbomify.com/CVE-2026-105753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105753
- OSV: https://osv.dev/vulnerability/CVE-2026-105753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105753/
Summaries are generated and may contain mistakes; the official description above is the record.
