# CVE-2026-105754: vLLM: Scale-out disaggregated multimodal transport trusts caller-supplied features

> Attackers can cause denial of service or retrieve cross-request cache state by sending malformed multimodal data to the vLLM inference endpoint.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-ph72-cqr5-qpp7, MINI-9qvv-g62j-xfp6, MINI-rrrx-2p2h-fqcc, MINI-vjjv-ghp2-q798, PYSEC-2026-4309

## What is CVE-2026-105754?

CVE-2026-105754 is a medium-severity vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, the /inference/v1/generate endpoint in the disaggregated scale-out path accepts caller-supplied tensors in the features.kwargs_data field, cache identifiers in the features.mm_hashes field, ranges in the features.mm_placeholders field, and wire-selected multimodal field processors without rebinding them to the active model renderer contract. Forged grid geometry, field types, or non-positive placeholder lengths can terminate the shared EngineCore; when an attacker knows or can induce a victim's content hash, forged cache hashes can poison or retrieve cross-request encoder-cache state; and dropped sparse placeholder masks can alter replayed transport semantics. This issue is fixed in version 0.30.0.

Weakness: CWE-704 (Incorrect Type Conversion or Cast), CWE-668 (Exposure of Resource to Wrong Sphere), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-617 (Reachable Assertion), CWE-20 (Improper Input Validation), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-105754?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.30.0 |
| `vllm` | PyPI | All versions | 0.30.0 |
| `vllm` | PyPI | All versions | 0.30.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-105754?

Upgrade vllm to 0.30.0 or later.

## Is CVE-2026-105754 being exploited?

There is no known exploitation of CVE-2026-105754 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105754 and fix it if it is affected.

What it is: CVE-2026-105754 is a medium-severity vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105754 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.30.0
- vllm (PyPI): affected all versions; fixed in 0.30.0
- vllm (PyPI): affected all versions; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105754/ (Markdown: https://insights.sbomify.com/CVE-2026-105754/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105754
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105754
- OSV: https://osv.dev/vulnerability/CVE-2026-105754

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105754/
Summaries are generated and may contain mistakes; the official description above is the record.
