# CVE-2026-105757: vLLM: Structured-output request errors escape the request boundary and terminate the shared EngineCore — engine-fatal denial of service (3 sites)

> Attackers can cause a denial of service in vLLM by sending structured-output requests that trigger unhandled exceptions, crashing the shared engine.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-85xf-c7hm-whqw, MINI-c6hv-9626-wgxg, MINI-c8qj-hf4w-8cp2, MINI-cx8c-m6j2-m62m, PYSEC-2026-4199

## What is CVE-2026-105757?

CVE-2026-105757 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, structured-output request failures can escape request-scoped validation and reach the EngineCore fatal-error path. A per-request backend mismatch can re-raise a grammar compilation exception, padding produced by the ngram_gpu speculative-decoding mode can pass a negative token to guidance validation, and the Rust frontend can admit empty structured-output values that the Python frontend rejects, allowing ordinary constrained-generation requests to terminate the shared engine. This issue is fixed in version 0.30.0.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-248 (Uncaught Exception), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-105757?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.30.0 |
| `vllm` | PyPI | All versions | 0.30.0 |
| `vllm` | PyPI | All versions | 0.30.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-105757?

Upgrade vllm to 0.30.0 or later.

## Is CVE-2026-105757 being exploited?

There is no known exploitation of CVE-2026-105757 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105757 and fix it if it is affected.

What it is: CVE-2026-105757 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105757 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.30.0
- vllm (PyPI): affected all versions; fixed in 0.30.0
- vllm (PyPI): affected all versions; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105757/ (Markdown: https://insights.sbomify.com/CVE-2026-105757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105757
- OSV: https://osv.dev/vulnerability/CVE-2026-105757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105757/
Summaries are generated and may contain mistakes; the official description above is the record.
