CVE-2026-105758 vLLM: Qwen2-VL / Qwen3-VL video samplers bound on request-controlled max_frames, which the num_frames ceiling does not reach

Medium 5.3 Published Updated

Unauthenticated attackers can cause denial of service in vLLM by submitting excessive video frame parameters to the tokenize endpoint.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105758?

CVE-2026-105758 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models. From 0.24.0 until 0.30.0, the Qwen2VLVideoBackend and Qwen3VLVideoBackend classes accept request-level values for the media_io_kwargs.video.max_frames and media_io_kwargs.video.fps fields without enforcing server-side ceilings. An unauthenticated caller can submit these values to the /tokenize endpoint, causing the sampler to decode every frame selected from attacker-controlled video input, consume disproportionate frontend memory, and potentially terminate the API process before scheduling or admission control. The Rust frontend is not affected because it rejects the media_io_kwargs field. This issue is fixed in version 0.30.0.

Weakness: CWE-770

Which versions are affected by CVE-2026-105758?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.24.00.30.0
vllm PyPIFrom 0.24.00.30.0
vllm PyPIFrom 0.24.00.30.0

Products include Vllm Vllm.

How do I fix CVE-2026-105758?

Upgrade vllm to 0.30.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-105758 being exploited?

There is no known exploitation of CVE-2026-105758 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-x6mc-67gf-chw4, MINI-23w5-pm9v-wh2f, MINI-fwvx-xj79-85gx, PYSEC-2026-4310.

Is CVE-2026-105758 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free