{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-105758 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.30.0 or later.","what":"CVE-2026-105758 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105758 and fix it if it is affected.\n\nWhat it is: CVE-2026-105758 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-105758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.24.0; fixed in 0.30.0\n- vllm (PyPI): affected from 0.24.0; fixed in 0.30.0\n- vllm (PyPI): affected from 0.24.0; fixed in 0.30.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105758/ (Markdown: https://insights.sbomify.com/CVE-2026-105758/index.md)","id":"CVE-2026-105758","markdown":"https://insights.sbomify.com/CVE-2026-105758/index.md","name":"CVE-2026-105758","record":{"aliases":["GHSA-x6mc-67gf-chw4","MINI-23w5-pm9v-wh2f","MINI-fwvx-xj79-85gx","PYSEC-2026-4310"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"none","summary":"Unauthenticated attackers can cause denial of service in vLLM by submitting excessive video frame parameters to the tokenize endpoint.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"vLLM is an inference and serving engine for large language models. From 0.24.0 until 0.30.0, the Qwen2VLVideoBackend and Qwen3VLVideoBackend classes accept request-level values for the media_io_kwargs.video.max_frames and media_io_kwargs.video.fps fields without enforcing server-side ceilings. An unauthenticated caller can submit these values to the /tokenize endpoint, causing the sampler to decode every frame selected from attacker-controlled video input, consume disproportionate frontend memory, and potentially terminate the API process before scheduling or admission control. The Rust frontend is not affected because it rejects the media_io_kwargs field. This issue is fixed in version 0.30.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM: Qwen2-VL / Qwen3-VL video samplers bound on request-controlled max_frames, which the num_frames ceiling does not reach","id":"CVE-2026-105758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Denial of service in vllm","id":"CVE-2026-105759"},"packages":[{"ecosystem":"PyPI","fixed":["0.30.0"],"introduced":["0.24.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-x6mc-67gf-chw4"},{"ecosystem":"PyPI","fixed":["0.30.0"],"introduced":["0.24.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-x6mc-67gf-chw4"},{"ecosystem":"PyPI","fixed":["0.30.0"],"introduced":["0.24.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-4310"}],"prev":{"headline":"vLLM: Structured-output request errors escape the request boundary and terminate the shared EngineCore — engine-fatal denial of service (3 sites)","id":"CVE-2026-105757"},"products":["vllm"],"published":"2026-10-05","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["vllm-project"]},"summary":"Unauthenticated attackers can cause denial of service in vLLM by submitting excessive video frame parameters to the tokenize endpoint.","url":"https://insights.sbomify.com/CVE-2026-105758/"}