# CVE-2026-105758: vLLM: Qwen2-VL / Qwen3-VL video samplers bound on request-controlled max_frames, which the num_frames ceiling does not reach

> Unauthenticated attackers can cause denial of service in vLLM by submitting excessive video frame parameters to the tokenize endpoint.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-x6mc-67gf-chw4, MINI-23w5-pm9v-wh2f, MINI-fwvx-xj79-85gx, PYSEC-2026-4310

## What is CVE-2026-105758?

CVE-2026-105758 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. From 0.24.0 until 0.30.0, the Qwen2VLVideoBackend and Qwen3VLVideoBackend classes accept request-level values for the media_io_kwargs.video.max_frames and media_io_kwargs.video.fps fields without enforcing server-side ceilings. An unauthenticated caller can submit these values to the /tokenize endpoint, causing the sampler to decode every frame selected from attacker-controlled video input, consume disproportionate frontend memory, and potentially terminate the API process before scheduling or admission control. The Rust frontend is not affected because it rejects the media_io_kwargs field. This issue is fixed in version 0.30.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-105758?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.24.0 | 0.30.0 |
| `vllm` | PyPI | From 0.24.0 | 0.30.0 |
| `vllm` | PyPI | From 0.24.0 | 0.30.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-105758?

Upgrade vllm to 0.30.0 or later.

## Is CVE-2026-105758 being exploited?

There is no known exploitation of CVE-2026-105758 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105758 and fix it if it is affected.

What it is: CVE-2026-105758 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105758 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.24.0; fixed in 0.30.0
- vllm (PyPI): affected from 0.24.0; fixed in 0.30.0
- vllm (PyPI): affected from 0.24.0; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105758/ (Markdown: https://insights.sbomify.com/CVE-2026-105758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105758
- OSV: https://osv.dev/vulnerability/CVE-2026-105758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105758/
Summaries are generated and may contain mistakes; the official description above is the record.
