# CVE-2026-105760: vLLM: GLMGA video sampling permits request-driven CPU and memory exhaustion

> Attackers can exhaust CPU and memory resources in vLLM by sending crafted requests with large video sampling parameters, causing service disruption.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-58v5-2m8f-94pr, MINI-ggw3-9mm2-x4m9, MINI-m33q-hwgg-4x7m, PYSEC-2026-4307

## What is CVE-2026-105760?

CVE-2026-105760 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, a caller can use the request-level media_io_kwargs field to select the GLMGA video backend and supply large values for the fps and max_frames options without a strict work ceiling. GLMGA constructs and deduplicates an attacker-sized pre-decode frame-index list, allowing a compact request and tiny valid video to consume disproportionate CPU time and memory in the shared media-loading executor. This issue is fixed in version 0.30.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-105760?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.23.0rc2 | 0.30.0 |
| `vllm` | PyPI | From 0.23.0rc2 | 0.30.0 |
| `vllm` | PyPI | From 0.23.0rc2 | 0.30.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-105760?

Upgrade vllm to 0.30.0 or later.

## Is CVE-2026-105760 being exploited?

There is no known exploitation of CVE-2026-105760 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105760 and fix it if it is affected.

What it is: CVE-2026-105760 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105760 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.23.0rc2; fixed in 0.30.0
- vllm (PyPI): affected from 0.23.0rc2; fixed in 0.30.0
- vllm (PyPI): affected from 0.23.0rc2; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105760/ (Markdown: https://insights.sbomify.com/CVE-2026-105760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105760
- OSV: https://osv.dev/vulnerability/CVE-2026-105760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105760/
Summaries are generated and may contain mistakes; the official description above is the record.
