{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-105768 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-105768 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-105768 is a medium-severity vulnerability in chainguard-dev apko, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105768 and fix it if it is affected.\n\nWhat it is: CVE-2026-105768 is a medium-severity vulnerability in chainguard-dev apko, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-105768 in the wild and no public exploit code.\n\nAffected product: chainguard-dev apko. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105768/ (Markdown: https://insights.sbomify.com/CVE-2026-105768/index.md)","id":"CVE-2026-105768","markdown":"https://insights.sbomify.com/CVE-2026-105768/index.md","name":"CVE-2026-105768","record":{"aliases":["GHSA-rj6x-hwpv-vhvf"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OCI image builder","requires_auth":"none","summary":"Attackers can force package-supplied entries to run as root by exploiting UID/GID truncation in apko, leading to privilege escalation in built images.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"chainguard","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-197","name":"Numeric Truncation Error"}],"description":"apko allows users to build and publish OCI container images built from apk packages. From version 0.2.0 to before version 1.4.5, UserEntry.Parse and GroupEntry.Parse in pkg/passwd read the UID and GID fields of /etc/passwd and /etc/group entries with strconv.Atoi and convert them to uint32 without a range check. On 64-bit platforms an out-of-range value such as 4294967296 (2^32) is truncated to 0, and negative values wrap. Because apko parses the passwd and group entries supplied by the packages it installs and writes them back into the image, an attacker who controls a package installed into the image can ship an entry that appears to declare an unprivileged UID or GID but is written into the built image as UID 0 or GID 0 (root). The truncated UID is also used when resolving the image's run-as user. This issue has been fixed in version 1.4.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"apko /etc/passwd and /etc/group UID/GID truncation writes package-supplied entries as root","id":"CVE-2026-105768","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Path Traversal (CWE-22) in FileArtifactService in Google ADK TypeScript (@google/adk) versions 0.4.0 before 0.6.0 allows a remote unauthenti","id":"CVE-2026-105772"},"packages":[],"prev":{"headline":"Chainguard Academy (edu) integrate-platform-docs composite action interpolates inputs into shell commands","id":"CVE-2026-105767"},"products":["apko"],"published":"2026-10-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["chainguard-dev"]},"summary":"Attackers can force package-supplied entries to run as root by exploiting UID/GID truncation in apko, leading to privilege escalation in built images.","url":"https://insights.sbomify.com/CVE-2026-105768/"}