{"answers":{"affected":"3 open source packages ship an affected version, including scrapy and Scrapy.","exploited":"There is no known exploitation of CVE-2026-105782 in the wild and no public exploit code.","fix":"Upgrade scrapy to 2.14.2 or later.","what":"CVE-2026-105782 is a high-severity code injection vulnerability in scrapy, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105782 and fix it if it is affected.\n\nWhat it is: CVE-2026-105782 is a high-severity code injection vulnerability in scrapy, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-105782 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- scrapy (PyPI): affected from 1.4.0; fixed in 2.14.2\n- scrapy (PyPI): affected from 1.4.0; fixed in 2.14.2\n- Scrapy (PyPI): affected from 1.4.0; fixed in 2.14.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105782/ (Markdown: https://insights.sbomify.com/CVE-2026-105782/index.md)","id":"CVE-2026-105782","markdown":"https://insights.sbomify.com/CVE-2026-105782/index.md","name":"CVE-2026-105782","record":{"aliases":["DEBIAN-CVE-2026-105782","GHSA-cwxj-rr6w-m6w7","PYSEC-2026-4299","UBUNTU-CVE-2026-105782"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web scraping framework","requires_auth":"none","summary":"A malicious website can cause arbitrary module import and execution via the Referrer-Policy header in Scrapy, leading to denial of service or code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"Scrapy is a high-level web crawling and scraping framework for Python. From 1.4.0 until 2.14.2, RefererMiddleware in scrapy/spidermiddlewares/referer.py treated a Referrer-Policy response-header value that resembled a Python import path as a referrer policy class, imported the referenced object, and called it. A malicious website could supply a callable such as sys.exit and terminate a crawler processing the response. This issue is fixed in version 2.14.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Scrapy: Arbitrary Module Import via Referrer-Policy Header in RefererMiddleware","id":"CVE-2026-105782","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Joplin Web Clipper pairing allows cross-origin theft of a permanent API token","id":"CVE-2026-105783"},"packages":[{"ecosystem":"PyPI","fixed":["2.14.2"],"introduced":["1.4.0"],"last_affected":[],"package":"Scrapy","purl":null,"source":"GHSA-cwxj-rr6w-m6w7"},{"ecosystem":"PyPI","fixed":["2.14.2"],"introduced":["1.4.0"],"last_affected":[],"package":"scrapy","purl":"pkg:pypi/scrapy","source":"GHSA-cwxj-rr6w-m6w7"},{"ecosystem":"PyPI","fixed":["2.14.2"],"introduced":["1.4.0"],"last_affected":[],"package":"scrapy","purl":"pkg:pypi/scrapy","source":"PYSEC-2026-4299"}],"prev":{"headline":"Adobe Campaign Classic (ACC) is affected by an Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerab","id":"CVE-2026-105781"},"products":["scrapy"],"published":"2026-10-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["scrapy"]},"summary":"A malicious website can cause arbitrary module import and execution via the Referrer-Policy header in Scrapy, leading to denial of service or code execution.","url":"https://insights.sbomify.com/CVE-2026-105782/"}