# CVE-2026-105782: Scrapy: Arbitrary Module Import via Referrer-Policy Header in RefererMiddleware

> A malicious website can cause arbitrary module import and execution via the Referrer-Policy header in Scrapy, leading to denial of service or code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-105782, GHSA-cwxj-rr6w-m6w7, PYSEC-2026-4299, UBUNTU-CVE-2026-105782

## What is CVE-2026-105782?

CVE-2026-105782 is a high-severity code injection vulnerability in scrapy, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Scrapy is a high-level web crawling and scraping framework for Python. From 1.4.0 until 2.14.2, RefererMiddleware in scrapy/spidermiddlewares/referer.py treated a Referrer-Policy response-header value that resembled a Python import path as a referrer policy class, imported the referenced object, and called it. A malicious website could supply a callable such as sys.exit and terminate a crawler processing the response. This issue is fixed in version 2.14.2.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-105782?

3 open source packages ship an affected version, including scrapy and Scrapy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scrapy` | PyPI | From 1.4.0 | 2.14.2 |
| `scrapy` | PyPI | From 1.4.0 | 2.14.2 |
| `Scrapy` | PyPI | From 1.4.0 | 2.14.2 |

## How do I fix CVE-2026-105782?

Upgrade scrapy to 2.14.2 or later.

## Is CVE-2026-105782 being exploited?

There is no known exploitation of CVE-2026-105782 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105782 and fix it if it is affected.

What it is: CVE-2026-105782 is a high-severity code injection vulnerability in scrapy, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105782 in the wild and no public exploit code.

Affected packages and fixed versions:
- scrapy (PyPI): affected from 1.4.0; fixed in 2.14.2
- scrapy (PyPI): affected from 1.4.0; fixed in 2.14.2
- Scrapy (PyPI): affected from 1.4.0; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105782/ (Markdown: https://insights.sbomify.com/CVE-2026-105782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105782
- OSV: https://osv.dev/vulnerability/CVE-2026-105782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105782/
Summaries are generated and may contain mistakes; the official description above is the record.
