# CVE-2026-105799: LangChain: RediSearch Filter Injection via Unescaped Tag/Text Values

> Attackers can inject RediSearch syntax to bypass access controls and read unauthorized indexed documents in LangChain Redis integrations.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** CLEANSTART-2026-TL42570, GHSA-5x6v-p487-7qh2

## What is CVE-2026-105799?

CVE-2026-105799 is a low-severity vulnerability in @langchain langchainjs, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LangChain is a framework for building LLM-powered applications. Prior to 1.1.1, @langchain/redis does not escape attacker-controlled values in structured RediSearch TAG filters and structured RediSearch TEXT filters, allowing injected RediSearch syntax to alter or broaden the generated search query. When an application uses an attacker-influenceable filter as a tenant or document-access boundary, the modified query can expose indexed documents outside the attacker's intended scope. This issue is fixed in version 1.1.1.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic)

## Which versions are affected by CVE-2026-105799?

2 open source packages ship an affected version, including @langchain/redis.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@langchain/redis` | npm | All versions | 1.1.1 |
| `@langchain/redis` | npm | All versions | 1.1.1 |

## How do I fix CVE-2026-105799?

Upgrade @langchain/redis to 1.1.1 or later.

## Is CVE-2026-105799 being exploited?

There is no known exploitation of CVE-2026-105799 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105799 and fix it if it is affected.

What it is: CVE-2026-105799 is a low-severity vulnerability in @langchain langchainjs, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105799 in the wild and no public exploit code.

Affected packages and fixed versions:
- @langchain/redis (npm): affected all versions; fixed in 1.1.1
- @langchain/redis (npm): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105799/ (Markdown: https://insights.sbomify.com/CVE-2026-105799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105799
- OSV: https://osv.dev/vulnerability/CVE-2026-105799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105799/
Summaries are generated and may contain mistakes; the official description above is the record.
