{"answers":{"affected":"2 open source packages ship an affected version, including i18next-http-backend.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105800 exists.","fix":"Upgrade i18next-http-backend to 4.0.2 or later.","what":"CVE-2026-105800 is a low-severity server-side request forgery vulnerability in i18next-http-backend, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105800 and fix it if it is affected.\n\nWhat it is: CVE-2026-105800 is a low-severity server-side request forgery vulnerability in i18next-http-backend, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105800 exists.\n\nAffected packages and fixed versions:\n- i18next-http-backend (npm): affected all versions; fixed in 4.0.2\n- i18next-http-backend (npm): affected all versions; fixed in 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105800/ (Markdown: https://insights.sbomify.com/CVE-2026-105800/index.md)","id":"CVE-2026-105800","markdown":"https://insights.sbomify.com/CVE-2026-105800/index.md","name":"CVE-2026-105800","record":{"aliases":["CLSA-2026-1792233117","CLSA-2026-1792233236","DEBIAN-CVE-2026-105800","GHSA-xvq9-wjp8-hwqf","UBUNTU-CVE-2026-105800"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"i18next HTTP backend","requires_auth":"none","summary":"Attackers can trigger SSRF or URL injection in i18next-http-backend by manipulating language or namespace values in custom load paths.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"i18next-http-backend is a backend layer for i18next that loads translation resources in Node.js, browsers, and Deno. Prior to 4.0.2, attacker-controlled language or namespace values interpolated into a custom loadPath or addPath that begins directly with {{lng}} or {{ns}} can make colon-based input become an absolute URL or, in browsers, make a double-slash namespace become a protocol-relative URL. The resulting request can leave the intended origin and cause URL injection or server-side request forgery. The default /locales/{{lng}}/{{ns}}.json template and templates with a leading path or origin are not affected because the placeholder does not occupy the URL's structural beginning. This issue is fixed in version 4.0.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"i18next-http-backend incomplete URL validation permits SSRF","id":"CVE-2026-105800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"openapi-python-client: Malicious OpenAPI Documents can cause Arbitrary Code Generation","id":"CVE-2026-105801"},"packages":[{"ecosystem":"npm","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"i18next-http-backend","purl":null,"source":"GHSA-xvq9-wjp8-hwqf"},{"ecosystem":"npm","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"i18next-http-backend","purl":"pkg:npm/i18next-http-backend","source":"GHSA-xvq9-wjp8-hwqf"}],"prev":{"headline":"LangChain: RediSearch Filter Injection via Unescaped Tag/Text Values","id":"CVE-2026-105799"},"products":["i18next-http-backend"],"published":"2026-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["i18next"]},"summary":"Attackers can trigger SSRF or URL injection in i18next-http-backend by manipulating language or namespace values in custom load paths.","url":"https://insights.sbomify.com/CVE-2026-105800/"}