{"answers":{"affected":"3 open source packages ship an affected version, including openapi-python-client.","exploited":"There is no known exploitation of CVE-2026-105801 in the wild and no public exploit code.","fix":"Upgrade openapi-python-client to 0.29.1 or later.","what":"CVE-2026-105801 is a high-severity code injection vulnerability in openapi-generators openapi-python-client, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-105801 and fix it if it is affected.\n\nWhat it is: CVE-2026-105801 is a high-severity code injection vulnerability in openapi-generators openapi-python-client, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-105801 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openapi-python-client (PyPI): affected all versions; fixed in 0.29.1\n- openapi-python-client (PyPI): affected all versions; fixed in 0.29.1\n- openapi-python-client (PyPI): affected all versions; fixed in 0.29.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105801/ (Markdown: https://insights.sbomify.com/CVE-2026-105801/index.md)","id":"CVE-2026-105801","markdown":"https://insights.sbomify.com/CVE-2026-105801/index.md","name":"CVE-2026-105801","record":{"aliases":["GHSA-5293-mq8x-g3xj","PYSEC-2026-4245"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python client generator","requires_auth":"none","summary":"Attackers can inject arbitrary Python code into generated clients via malicious OpenAPI documents, leading to code execution when the client is imported.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"openapi-python-client generates Python clients from OpenAPI documents. Prior to 0.29.1, the generator does not safely neutralize malicious OpenAPI document content before rendering string, docstring, and f-string contexts in generated Python. The generated Python client can contain attacker-controlled Python that executes when a user imports the client, affecting the importing environment's integrity and potentially its confidentiality and availability. This issue is fixed in version 0.29.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"openapi-python-client: Malicious OpenAPI Documents can cause Arbitrary Code Generation","id":"CVE-2026-105801","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Payload: Password hashes use insufficient PBKDF2 iterations","id":"CVE-2026-105804"},"packages":[{"ecosystem":"PyPI","fixed":["0.29.1"],"introduced":["0"],"last_affected":[],"package":"openapi-python-client","purl":null,"source":"GHSA-5293-mq8x-g3xj"},{"ecosystem":"PyPI","fixed":["0.29.1"],"introduced":["0"],"last_affected":[],"package":"openapi-python-client","purl":"pkg:pypi/openapi-python-client","source":"GHSA-5293-mq8x-g3xj"},{"ecosystem":"PyPI","fixed":["0.29.1"],"introduced":["0"],"last_affected":[],"package":"openapi-python-client","purl":"pkg:pypi/openapi-python-client","source":"PYSEC-2026-4245"}],"prev":{"headline":"i18next-http-backend incomplete URL validation permits SSRF","id":"CVE-2026-105800"},"products":["openapi-python-client"],"published":"2026-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-09","vendors":["openapi-generators"]},"summary":"Attackers can inject arbitrary Python code into generated clients via malicious OpenAPI documents, leading to code execution when the client is imported.","url":"https://insights.sbomify.com/CVE-2026-105801/"}