# CVE-2026-105801: openapi-python-client: Malicious OpenAPI Documents can cause Arbitrary Code Generation

> Attackers can inject arbitrary Python code into generated clients via malicious OpenAPI documents, leading to code execution when the client is imported.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-5293-mq8x-g3xj, PYSEC-2026-4245

## What is CVE-2026-105801?

CVE-2026-105801 is a high-severity code injection vulnerability in openapi-generators openapi-python-client, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

openapi-python-client generates Python clients from OpenAPI documents. Prior to 0.29.1, the generator does not safely neutralize malicious OpenAPI document content before rendering string, docstring, and f-string contexts in generated Python. The generated Python client can contain attacker-controlled Python that executes when a user imports the client, affecting the importing environment's integrity and potentially its confidentiality and availability. This issue is fixed in version 0.29.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-105801?

3 open source packages ship an affected version, including openapi-python-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openapi-python-client` | PyPI | All versions | 0.29.1 |
| `openapi-python-client` | PyPI | All versions | 0.29.1 |
| `openapi-python-client` | PyPI | All versions | 0.29.1 |

## How do I fix CVE-2026-105801?

Upgrade openapi-python-client to 0.29.1 or later.

## Is CVE-2026-105801 being exploited?

There is no known exploitation of CVE-2026-105801 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105801 and fix it if it is affected.

What it is: CVE-2026-105801 is a high-severity code injection vulnerability in openapi-generators openapi-python-client, published on 6 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-105801 in the wild and no public exploit code.

Affected packages and fixed versions:
- openapi-python-client (PyPI): affected all versions; fixed in 0.29.1
- openapi-python-client (PyPI): affected all versions; fixed in 0.29.1
- openapi-python-client (PyPI): affected all versions; fixed in 0.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105801/ (Markdown: https://insights.sbomify.com/CVE-2026-105801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105801
- OSV: https://osv.dev/vulnerability/CVE-2026-105801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105801/
Summaries are generated and may contain mistakes; the official description above is the record.
