CVE-2026-105804 Payload: Password hashes use insufficient PBKDF2 iterations
Payload CMS uses insufficient PBKDF2 iterations for password hashing, making recovered hashes easier to crack.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-105804?
CVE-2026-105804 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Payload is a free and open source headless content management system. Payload versions from 3.0.0 before 3.90.0 and canary versions from 4.0.0-canary.0 before 4.0.0-canary.34 use a lower-than-recommended PBKDF2 work factor for password hashing, reducing the computational effort required to test recovered password hashes. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Weakness: CWE-916
Which versions are affected by CVE-2026-105804?
4 open source packages ship an affected version, including payload.
| Package | Affected | Fixed in |
|---|---|---|
payload npm | From 3.0.0 | 3.90.0 |
payload npm | From 3.0.0 | 3.90.0 |
payload npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |
payload npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |
How do I fix CVE-2026-105804?
Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.
Is CVE-2026-105804 being exploited?
There is no known exploitation of CVE-2026-105804 in the wild and no public exploit code.
Sources
Also known as GHSA-q6mq-ch85-c8mm.