{"answers":{"affected":"4 open source packages ship an affected version, including payload.","exploited":"There is no known exploitation of CVE-2026-105804 in the wild and no public exploit code.","fix":"Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.","what":"CVE-2026-105804 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105804 and fix it if it is affected.\n\nWhat it is: CVE-2026-105804 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-105804 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- payload (npm): affected from 3.0.0; fixed in 3.90.0\n- payload (npm): affected from 3.0.0; fixed in 3.90.0\n- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34\n- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105804/ (Markdown: https://insights.sbomify.com/CVE-2026-105804/index.md)","id":"CVE-2026-105804","markdown":"https://insights.sbomify.com/CVE-2026-105804/index.md","name":"CVE-2026-105804","record":{"aliases":["GHSA-q6mq-ch85-c8mm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Payload CMS","requires_auth":"high_privilege","summary":"Payload CMS uses insufficient PBKDF2 iterations for password hashing, making recovered hashes easier to crack.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-916","name":"Use of Password Hash With Insufficient Computational Effort"}],"description":"Payload is a free and open source headless content management system. Payload versions from 3.0.0 before 3.90.0 and canary versions from 4.0.0-canary.0 before 4.0.0-canary.34 use a lower-than-recommended PBKDF2 work factor for password hashing, reducing the computational effort required to test recovered password hashes. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Payload: Password hashes use insufficient PBKDF2 iterations","id":"CVE-2026-105804","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Payload: Sort queries could expose protected field information","id":"CVE-2026-105805"},"packages":[{"ecosystem":"npm","fixed":["3.90.0"],"introduced":["3.0.0"],"last_affected":[],"package":"payload","purl":null,"source":"GHSA-q6mq-ch85-c8mm"},{"ecosystem":"npm","fixed":["3.90.0"],"introduced":["3.0.0"],"last_affected":[],"package":"payload","purl":"pkg:npm/payload","source":"GHSA-q6mq-ch85-c8mm"},{"ecosystem":"npm","fixed":["4.0.0-canary.34"],"introduced":["4.0.0-canary.0"],"last_affected":[],"package":"payload","purl":null,"source":"GHSA-q6mq-ch85-c8mm"},{"ecosystem":"npm","fixed":["4.0.0-canary.34"],"introduced":["4.0.0-canary.0"],"last_affected":[],"package":"payload","purl":"pkg:npm/payload","source":"GHSA-q6mq-ch85-c8mm"}],"prev":{"headline":"openapi-python-client: Malicious OpenAPI Documents can cause Arbitrary Code Generation","id":"CVE-2026-105801"},"products":["payload"],"published":"2026-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["payloadcms"]},"summary":"Payload CMS uses insufficient PBKDF2 iterations for password hashing, making recovered hashes easier to crack.","url":"https://insights.sbomify.com/CVE-2026-105804/"}