# CVE-2026-105804: Payload: Password hashes use insufficient PBKDF2 iterations

> Payload CMS uses insufficient PBKDF2 iterations for password hashing, making recovered hashes easier to crack.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-q6mq-ch85-c8mm

## What is CVE-2026-105804?

CVE-2026-105804 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Payload is a free and open source headless content management system. Payload versions from 3.0.0 before 3.90.0 and canary versions from 4.0.0-canary.0 before 4.0.0-canary.34 use a lower-than-recommended PBKDF2 work factor for password hashing, reducing the computational effort required to test recovered password hashes. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-916 (Use of Password Hash With Insufficient Computational Effort)

## Which versions are affected by CVE-2026-105804?

4 open source packages ship an affected version, including payload.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `payload` | npm | From 3.0.0 | 3.90.0 |
| `payload` | npm | From 3.0.0 | 3.90.0 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |

## How do I fix CVE-2026-105804?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

## Is CVE-2026-105804 being exploited?

There is no known exploitation of CVE-2026-105804 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105804 and fix it if it is affected.

What it is: CVE-2026-105804 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105804 in the wild and no public exploit code.

Affected packages and fixed versions:
- payload (npm): affected from 3.0.0; fixed in 3.90.0
- payload (npm): affected from 3.0.0; fixed in 3.90.0
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105804/ (Markdown: https://insights.sbomify.com/CVE-2026-105804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105804
- OSV: https://osv.dev/vulnerability/CVE-2026-105804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105804/
Summaries are generated and may contain mistakes; the official description above is the record.
