CVE-2026-105805 Payload: Sort queries could expose protected field information

Medium 6.9 Published Updated

An untrusted user can infer protected field values by manipulating sort parameters in Payload CMS queries.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105805?

CVE-2026-105805 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In versions before 3.88.0 and canary versions before 4.0.0-canary.27, an untrusted user who can query a readable collection, control its sorting, and select a protected field as the sort parameter can infer limited information about field values the user cannot read. This issue is fixed in versions 3.88.0 and 4.0.0-canary.27.

Weakness: CWE-863, CWE-200

Which versions are affected by CVE-2026-105805?

4 open source packages ship an affected version, including payload.

PackageAffectedFixed in
payload npmAll versions3.88.0
payload npmAll versions3.88.0
payload npmFrom 4.0.0-canary.04.0.0-canary.27
payload npmFrom 4.0.0-canary.04.0.0-canary.27

How do I fix CVE-2026-105805?

Upgrade payload to a fixed version for your release line: 3.88.0 or 4.0.0-canary.27.

Is CVE-2026-105805 being exploited?

There is no known exploitation of CVE-2026-105805 in the wild and no public exploit code.

Sources

Also known as GHSA-9g87-32v6-3c2r.

Is CVE-2026-105805 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free