{"answers":{"affected":"4 open source packages ship an affected version, including payload.","exploited":"There is no known exploitation of CVE-2026-105805 in the wild and no public exploit code.","fix":"Upgrade payload to a fixed version for your release line: 3.88.0 or 4.0.0-canary.27.","what":"CVE-2026-105805 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105805 and fix it if it is affected.\n\nWhat it is: CVE-2026-105805 is a medium-severity vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-105805 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- payload (npm): affected all versions; fixed in 3.88.0\n- payload (npm): affected all versions; fixed in 3.88.0\n- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27\n- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105805/ (Markdown: https://insights.sbomify.com/CVE-2026-105805/index.md)","id":"CVE-2026-105805","markdown":"https://insights.sbomify.com/CVE-2026-105805/index.md","name":"CVE-2026-105805","record":{"aliases":["GHSA-9g87-32v6-3c2r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Headless CMS","requires_auth":"none","summary":"An untrusted user can infer protected field values by manipulating sort parameters in Payload CMS queries.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Payload is a free and open source headless content management system. In versions before 3.88.0 and canary versions before 4.0.0-canary.27, an untrusted user who can query a readable collection, control its sorting, and select a protected field as the sort parameter can infer limited information about field values the user cannot read. This issue is fixed in versions 3.88.0 and 4.0.0-canary.27.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Payload: Sort queries could expose protected field information","id":"CVE-2026-105805","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Payload: Improper access control for MCP API keys","id":"CVE-2026-105806"},"packages":[{"ecosystem":"npm","fixed":["3.88.0"],"introduced":["0"],"last_affected":[],"package":"payload","purl":null,"source":"GHSA-9g87-32v6-3c2r"},{"ecosystem":"npm","fixed":["3.88.0"],"introduced":["0"],"last_affected":[],"package":"payload","purl":"pkg:npm/payload","source":"GHSA-9g87-32v6-3c2r"},{"ecosystem":"npm","fixed":["4.0.0-canary.27"],"introduced":["4.0.0-canary.0"],"last_affected":[],"package":"payload","purl":null,"source":"GHSA-9g87-32v6-3c2r"},{"ecosystem":"npm","fixed":["4.0.0-canary.27"],"introduced":["4.0.0-canary.0"],"last_affected":[],"package":"payload","purl":"pkg:npm/payload","source":"GHSA-9g87-32v6-3c2r"}],"prev":{"headline":"Payload: Password hashes use insufficient PBKDF2 iterations","id":"CVE-2026-105804"},"products":["payload"],"published":"2026-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-06","vendors":["payloadcms"]},"summary":"An untrusted user can infer protected field values by manipulating sort parameters in Payload CMS queries.","url":"https://insights.sbomify.com/CVE-2026-105805/"}