# CVE-2026-105806: Payload: Improper access control for MCP API keys

> An authenticated user can manage MCP API keys outside their account, leading to privilege escalation and account takeover in Payload CMS.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-2q76-m6w6-qgc6

## What is CVE-2026-105806?

CVE-2026-105806 is a high-severity missing authorization vulnerability in @payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Payload is a free and open source headless content management system. In @payloadcms/plugin-mcp versions from 3.61.0 until 3.88.0, an authenticated user can manage MCP API keys outside the intended account, enabling privilege escalation through account takeover. This issue is fixed in version 3.88.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-105806?

2 open source packages ship an affected version, including @payloadcms/plugin-mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@payloadcms/plugin-mcp` | npm | From 3.61.0 | 3.88.0 |
| `@payloadcms/plugin-mcp` | npm | From 3.61.0 | 3.88.0 |

## How do I fix CVE-2026-105806?

Upgrade @payloadcms/plugin-mcp to 3.88.0 or later.

## Is CVE-2026-105806 being exploited?

There is no known exploitation of CVE-2026-105806 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105806 and fix it if it is affected.

What it is: CVE-2026-105806 is a high-severity missing authorization vulnerability in @payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105806 in the wild and no public exploit code.

Affected packages and fixed versions:
- @payloadcms/plugin-mcp (npm): affected from 3.61.0; fixed in 3.88.0
- @payloadcms/plugin-mcp (npm): affected from 3.61.0; fixed in 3.88.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105806/ (Markdown: https://insights.sbomify.com/CVE-2026-105806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105806
- OSV: https://osv.dev/vulnerability/CVE-2026-105806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105806/
Summaries are generated and may contain mistakes; the official description above is the record.
