# CVE-2026-105816: Vault Vulnerable to Arbitrary Code Execution via Plugin Catalog Entries Restored From Raft Snapshots

> Privileged operators can execute arbitrary code on Vault hosts by restoring Raft snapshots with malicious plugin catalog entries when external plugin directories are configured.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** BIT-vault-2026-105816, GHSA-pw8v-gjgv-3j42, MINI-662g-vvv9-r552

## What is CVE-2026-105816?

CVE-2026-105816 is a high-severity path traversal vulnerability in HashiCorp Vault, published on 7 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Vault and Vault Enterprise did not consistently verify that stored plugin catalog entries reference binaries within the configured plugin directory. When Vault uses Shamir seals and has an external plugin directory configured, a privileged operator able to restore an Integrated Storage (Raft) snapshot may be able to execute arbitrary code on the Vault host. This vulnerability (CVE-2026-105816) is fixed in Vault Community Edition 2.1.2, and Vault Enterprise 2.1.2, 1.21.12, 1.20.17, and 1.19.23.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-105816?

1 open source package ship an affected version, including vault.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 0.0.1 | 2.1.2 |

## How do I fix CVE-2026-105816?

Upgrade vault to 2.1.2 or later.

## Is CVE-2026-105816 being exploited?

There is no known exploitation of CVE-2026-105816 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105816 and fix it if it is affected.

What it is: CVE-2026-105816 is a high-severity path traversal vulnerability in HashiCorp Vault, published on 7 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105816 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 0.0.1; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105816/ (Markdown: https://insights.sbomify.com/CVE-2026-105816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105816
- OSV: https://osv.dev/vulnerability/CVE-2026-105816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105816/
Summaries are generated and may contain mistakes; the official description above is the record.
