CVE-2026-105818 Vault PKI ACME Issues Certificate With Unvalidated SANs
Attackers can obtain certificates with unverified identities via ACME, enabling impersonation against systems trusting the Vault PKI mount.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-105818?
CVE-2026-105818 is a medium-severity missing authorization vulnerability in HashiCorp Vault, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vault's PKI secrets engine ACME server did not restrict certificate identities that ACME challenges do not validate when issuing certificates under the default directory policy. This may allow an ACME client to obtain a certificate containing unverified identity claims, potentially enabling impersonation toward systems that trust certificates issued by the affected Vault PKI mount. This vulnerability (CVE-2026-105818) is fixed in Vault Community Edition 2.1.2, and Vault Enterprise 2.1.2, 1.21.12, 1.20.17, and 1.19.23.
Weakness: CWE-345
Which versions are affected by CVE-2026-105818?
1 open source package ship an affected version, including vault.
| Package | Affected | Fixed in |
|---|---|---|
vault Bitnami | From 1.14.0 | 2.1.2 |
How do I fix CVE-2026-105818?
Upgrade vault to 2.1.2 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-105818 being exploited?
There is no known exploitation of CVE-2026-105818 in the wild and no public exploit code.
Sources
Also known as BIT-vault-2026-105818, GHSA-fxww-hx7x-vxpc, MINI-hgj5-77cw-7mq2.