# CVE-2026-105818: Vault PKI ACME Issues Certificate With Unvalidated SANs

> Attackers can obtain certificates with unverified identities via ACME, enabling impersonation against systems trusting the Vault PKI mount.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-vault-2026-105818, GHSA-fxww-hx7x-vxpc, MINI-hgj5-77cw-7mq2

## What is CVE-2026-105818?

CVE-2026-105818 is a medium-severity missing authorization vulnerability in HashiCorp Vault, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vault's PKI secrets engine ACME server did not restrict certificate identities that ACME challenges do not validate when issuing certificates under the default directory policy. This may allow an ACME client to obtain a certificate containing unverified identity claims, potentially enabling impersonation toward systems that trust certificates issued by the affected Vault PKI mount. This vulnerability (CVE-2026-105818) is fixed in Vault Community Edition 2.1.2, and Vault Enterprise 2.1.2, 1.21.12, 1.20.17, and 1.19.23.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-105818?

1 open source package ship an affected version, including vault.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 1.14.0 | 2.1.2 |

## How do I fix CVE-2026-105818?

Upgrade vault to 2.1.2 or later.

## Is CVE-2026-105818 being exploited?

There is no known exploitation of CVE-2026-105818 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105818 and fix it if it is affected.

What it is: CVE-2026-105818 is a medium-severity missing authorization vulnerability in HashiCorp Vault, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105818 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 1.14.0; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105818/ (Markdown: https://insights.sbomify.com/CVE-2026-105818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105818
- OSV: https://osv.dev/vulnerability/CVE-2026-105818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105818/
Summaries are generated and may contain mistakes; the official description above is the record.
