# CVE-2026-105828: Parse Server 9.0.0 before 9.10.1-alpha.12 Class Name Disclosure via GraphQL Errors

> Unauthenticated attackers can discover hidden class names via GraphQL error messages when public introspection is disabled, exposing internal schema details.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-parse-2026-105828, GHSA-6m77-f8xr-f723, GHSA-c9g3-rrm7-955v

## What is CVE-2026-105828?

CVE-2026-105828 is a medium-severity vulnerability in parse-community parse-server, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server 8.2.2 before 8.6.92 and 9.0.0 before 9.10.1-alpha.12 contains an information disclosure vulnerability in which GraphQL validation error messages reveal hidden class names when public introspection is disabled. Unauthenticated attackers holding only the public Application Id can send crafted operations triggering unknown-argument or invalid enum value errors to learn pointer and relation target classes.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-105828?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | From 8.2.2 | 8.6.92, 9.10.1 |

## How do I fix CVE-2026-105828?

Upgrade parse to a fixed version for your release line: 8.6.92 or 9.10.1.

## Is CVE-2026-105828 being exploited?

There is no known exploitation of CVE-2026-105828 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105828 and fix it if it is affected.

What it is: CVE-2026-105828 is a medium-severity vulnerability in parse-community parse-server, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105828 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected from 8.2.2; fixed in 8.6.92, 9.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105828/ (Markdown: https://insights.sbomify.com/CVE-2026-105828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105828
- OSV: https://osv.dev/vulnerability/CVE-2026-105828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105828/
Summaries are generated and may contain mistakes; the official description above is the record.
