# CVE-2026-105829: League CommonMark 1.3.0 before 2.10.2 Stored XSS via DisallowedRawHtml Bypass

> Attackers can execute stored scripts in viewers' browsers by bypassing raw HTML restrictions in the League CommonMark Markdown parser.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 10 Oct 2026
- **Also known as:** CLSA-2026-1791458521, DEBIAN-CVE-2026-105829, GHSA-6vmm-7pc2-g2g6, GHSA-97jj-33gv-5xf9, UBUNTU-CVE-2026-105829

## What is CVE-2026-105829?

CVE-2026-105829 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

League CommonMark from 1.3.0 before 2.10.2 contains a cross-site scripting vulnerability that allows users posting Markdown to bypass the DisallowedRawHtml extension by ending raw HTML with a bare disallowed tag name. Attackers can place a lone <script or <iframe line followed by a block supplying attributes like src or onload, executing stored scripts in viewers' browsers under default GFM settings.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-105829?

2 open source packages ship an affected version, including league/commonmark.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 1.3.0 | 2.10.2 |
| `league/commonmark` | Packagist | From 1.3.0 | 2.10.2 |

## How do I fix CVE-2026-105829?

Upgrade league/commonmark to 2.10.2 or later.

## Is CVE-2026-105829 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105829 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105829 and fix it if it is affected.

What it is: CVE-2026-105829 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105829 exists.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 1.3.0; fixed in 2.10.2
- league/commonmark (Packagist): affected from 1.3.0; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105829/ (Markdown: https://insights.sbomify.com/CVE-2026-105829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105829
- OSV: https://osv.dev/vulnerability/CVE-2026-105829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105829/
Summaries are generated and may contain mistakes; the official description above is the record.
