# CVE-2026-105830: league/commonmark 2.0.0 before 2.10.2 Quadratic DoS via TableStartParser

> Unauthenticated attackers can cause CPU exhaustion and denial of service in league/commonmark by submitting crafted Markdown input.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-105830, GHSA-3q6v-r5mr-hxv8, GHSA-84wr-wccg-f5hp, UBUNTU-CVE-2026-105830

## What is CVE-2026-105830?

CVE-2026-105830 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

league/commonmark from 2.0.0 before 2.10.2 contains a quadratic-time denial of service vulnerability in the GitHub Flavored Markdown Table extension's TableStartParser::tryStart() block-start scan. Unauthenticated attackers can submit a large paragraph of pipe-free lines not starting with letters, forcing repeated full-buffer strpos scans that exhaust PHP worker CPU.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-105830?

2 open source packages ship an affected version, including league/commonmark.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 2.0.0 | 2.10.2 |
| `league/commonmark` | Packagist | From 2.0.0 | 2.10.2 |

## How do I fix CVE-2026-105830?

Upgrade league/commonmark to 2.10.2 or later.

## Is CVE-2026-105830 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105830 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105830 and fix it if it is affected.

What it is: CVE-2026-105830 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105830 exists.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 2.0.0; fixed in 2.10.2
- league/commonmark (Packagist): affected from 2.0.0; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105830/ (Markdown: https://insights.sbomify.com/CVE-2026-105830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105830
- OSV: https://osv.dev/vulnerability/CVE-2026-105830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105830/
Summaries are generated and may contain mistakes; the official description above is the record.
