# CVE-2026-10584: HTTPS Fallback to HTTP in Graph Explorer

> Attackers can intercept sensitive data by exploiting an HTTPS to HTTP fallback when certificates are missing in Graph Explorer.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026

## What is CVE-2026-10584?

CVE-2026-10584 is a high-severity vulnerability in AWS Graph Explorer, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Proxy server in Graph Explorer before 3.0.1 falls back to HTTP when certificate files are missing, which might allow remote threat actors to obtain sensitive information via interception of requests intended to be sent over HTTPS.

To remediate this issue, users should upgrade to Graph Explorer v3.0.1 or later.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2026-10584?


## How do I fix CVE-2026-10584?

No fix has been published for CVE-2026-10584 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-10584 being exploited?

There is no known exploitation of CVE-2026-10584 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10584 and fix it if it is affected.

What it is: CVE-2026-10584 is a high-severity vulnerability in AWS Graph Explorer, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-10584 in the wild and no public exploit code.

Affected product: AWS Graph Explorer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10584/ (Markdown: https://insights.sbomify.com/CVE-2026-10584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10584
- OSV: https://osv.dev/vulnerability/CVE-2026-10584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10584/
Summaries are generated and may contain mistakes; the official description above is the record.
