CVE-2026-105844 Payload: Prototype pollution in Payload Import Export plugin
Unauthenticated attackers can achieve remote code execution via prototype pollution in the Payload CMS Import Export plugin when enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-105844?
CVE-2026-105844 is a critical code injection vulnerability in @payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.88.0 and canary versions before 4.0.0-canary.27, an unauthenticated user can submit prototype-sensitive field paths when @payloadcms/plugin-import-export is enabled, causing unintended application behavior that can lead to remote code execution. This issue is fixed in versions 3.88.0 and 4.0.0-canary.27.
Weakness: CWE-1321
Which versions are affected by CVE-2026-105844?
4 open source packages ship an affected version, including @payloadcms/plugin-import-export.
| Package | Affected | Fixed in |
|---|---|---|
@payloadcms/plugin-import-export npm | From 3.0.0 | 3.88.0 |
@payloadcms/plugin-import-export npm | From 3.0.0 | 3.88.0 |
@payloadcms/plugin-import-export npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |
@payloadcms/plugin-import-export npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |
How do I fix CVE-2026-105844?
Upgrade @payloadcms/plugin-import-export to a fixed version for your release line: 3.88.0 or 4.0.0-canary.27.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-105844 being exploited?
There is no known exploitation of CVE-2026-105844 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-qf28-8hc6-vwrp.