# CVE-2026-105845: Payload: SQL Injection in SQLite and Postgres

> An untrusted user can exploit dynamic filters or joins to perform SQL injection in SQLite and Postgres adapters, potentially reading or modifying data.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-v49j-62m6-pgrr

## What is CVE-2026-105845?

CVE-2026-105845 is a critical SQL injection vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.88.0 and canary versions before 4.0.0-canary.27, an untrusted user who can query readable collections through dynamic filters or joins can submit a request that causes SQL injection in the SQLite and Postgres adapters. This issue is fixed in versions 3.88.0 and 4.0.0-canary.27.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-105845?

4 open source packages ship an affected version, including payload.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `payload` | npm | From 3.0.0 | 3.88.0 |
| `payload` | npm | From 3.0.0 | 3.88.0 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |

## How do I fix CVE-2026-105845?

Upgrade payload to a fixed version for your release line: 3.88.0 or 4.0.0-canary.27.

## Is CVE-2026-105845 being exploited?

There is no known exploitation of CVE-2026-105845 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105845 and fix it if it is affected.

What it is: CVE-2026-105845 is a critical SQL injection vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105845 in the wild and no public exploit code.

Affected packages and fixed versions:
- payload (npm): affected from 3.0.0; fixed in 3.88.0
- payload (npm): affected from 3.0.0; fixed in 3.88.0
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105845/ (Markdown: https://insights.sbomify.com/CVE-2026-105845/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105845
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105845
- OSV: https://osv.dev/vulnerability/CVE-2026-105845

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105845/
Summaries are generated and may contain mistakes; the official description above is the record.
