# CVE-2026-105846: Payload: Untrusted redirect URL parameter exploit

> Attackers can redirect users to malicious sites after authentication, potentially facilitating phishing or credential theft in Payload CMS.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-w84c-53h3-mc2g

## What is CVE-2026-105846?

CVE-2026-105846 is a medium-severity vulnerability in @payloadcms next, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Payload is a free and open source headless content management system. In versions from 3.40.0 before 3.88.0 and canary versions before 4.0.0-canary.27, an attacker can craft a redirect URL parameter that sends a guest user to an untrusted destination after the authentication flow completes. This issue is fixed in versions 3.88.0 and 4.0.0-canary.27.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-105846?

8 open source packages ship an affected version, including @payloadcms/next and payload. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@payloadcms/next` | npm | From 3.31.0 | 3.88.0 |
| `@payloadcms/next` | npm | From 3.31.0 | 3.88.0 |
| `@payloadcms/next` | npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |
| `@payloadcms/next` | npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |
| `payload` | npm | From 3.40.0 | 3.88.0 |
| `payload` | npm | From 3.40.0 | 3.88.0 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.27 |

Products: Payloadcms Payload.

## How do I fix CVE-2026-105846?

Upgrade @payloadcms/next to a fixed version for your release line: 3.88.0 or 4.0.0-canary.27.

## Is CVE-2026-105846 being exploited?

There is no known exploitation of CVE-2026-105846 in the wild and no public exploit code.

## Other vulnerabilities in @payloadcms next

- [CVE-2026-105857](https://insights.sbomify.com/CVE-2026-105857/): Payload: RCE in Payload Form Builder (critical 10.0)
- [CVE-2026-105859](https://insights.sbomify.com/CVE-2026-105859/): Payload: Unauthorized update to collection documents (critical 9.8)
- [CVE-2026-25544](https://insights.sbomify.com/CVE-2026-25544/): Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters (critical 9.8)
- [CVE-2022-27952](https://insights.sbomify.com/CVE-2022-27952/): Unrestricted Upload of File with Dangerous Type in Payload (critical 9.8)
- [CVE-2026-105851](https://insights.sbomify.com/CVE-2026-105851/): Payload: Field access control bypass on auth collections (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105846 and fix it if it is affected.

What it is: CVE-2026-105846 is a medium-severity vulnerability in @payloadcms next, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-105846 in the wild and no public exploit code.

Affected packages and fixed versions:
- @payloadcms/next (npm): affected from 3.31.0; fixed in 3.88.0
- @payloadcms/next (npm): affected from 3.31.0; fixed in 3.88.0
- @payloadcms/next (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27
- @payloadcms/next (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27
- payload (npm): affected from 3.40.0; fixed in 3.88.0
- payload (npm): affected from 3.40.0; fixed in 3.88.0
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105846/ (Markdown: https://insights.sbomify.com/CVE-2026-105846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105846
- OSV: https://osv.dev/vulnerability/CVE-2026-105846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105846/
Summaries are generated and may contain mistakes; the official description above is the record.
