CVE-2026-105847 Payload: Polymorphic join queries could disclose hidden fields

High 7.1 Published Updated

Attackers can infer hidden or restricted values, such as password-reset tokens, by exploiting polymorphic join queries in the Payload CMS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105847?

CVE-2026-105847 is a high-severity vulnerability in payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, a user who can query a collection with a polymorphic join to sensitive fields can infer hidden or read-restricted values, including password-reset tokens, through polymorphic join filters. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-639, CWE-200

Which versions are affected by CVE-2026-105847?

4 open source packages ship an affected version, including payload. It affects 1 product.

PackageAffectedFixed in
payload npmFrom 3.0.03.90.0
payload npmFrom 3.0.03.90.0
payload npmFrom 4.0.0-canary.04.0.0-canary.34
payload npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105847?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Is CVE-2026-105847 being exploited?

There is no known exploitation of CVE-2026-105847 in the wild and no public exploit code.

Sources

Also known as GHSA-fpww-c55p-cjv6.

Is CVE-2026-105847 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free