CVE-2026-105848 Payload: Insufficient Access Control in Stripe REST Proxy

Medium 6.4 Published Updated

Authenticated users can perform unintended Stripe operations via the REST proxy due to insufficient access control in the Payload CMS Stripe plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105848?

CVE-2026-105848 is a medium-severity missing authorization vulnerability in @payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user who can reach the enabled optional Stripe REST proxy can perform unintended Stripe operations. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-862, CWE-749

Which versions are affected by CVE-2026-105848?

4 open source packages ship an affected version, including @payloadcms/plugin-stripe. It affects 1 product.

PackageAffectedFixed in
@payloadcms/plugin-stripe npmAll versions3.90.0
@payloadcms/plugin-stripe npmAll versions3.90.0
@payloadcms/plugin-stripe npmFrom 4.0.0-canary.04.0.0-canary.34
@payloadcms/plugin-stripe npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105848?

Upgrade @payloadcms/plugin-stripe to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-105848 being exploited?

There is no known exploitation of CVE-2026-105848 in the wild and no public exploit code.

Sources

Also known as GHSA-r9v2-gg2j-22q5.

Is CVE-2026-105848 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free