{"answers":{"affected":"4 open source packages ship an affected version, including @payloadcms/plugin-stripe. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-105848 in the wild and no public exploit code.","fix":"Upgrade @payloadcms/plugin-stripe to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.","what":"CVE-2026-105848 is a medium-severity missing authorization vulnerability in @payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-105848 and fix it if it is affected.\n\nWhat it is: CVE-2026-105848 is a medium-severity missing authorization vulnerability in @payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-105848 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @payloadcms/plugin-stripe (npm): affected all versions; fixed in 3.90.0\n- @payloadcms/plugin-stripe (npm): affected all versions; fixed in 3.90.0\n- @payloadcms/plugin-stripe (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34\n- @payloadcms/plugin-stripe (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-105848/ (Markdown: https://insights.sbomify.com/CVE-2026-105848/index.md)","id":"CVE-2026-105848","markdown":"https://insights.sbomify.com/CVE-2026-105848/index.md","name":"CVE-2026-105848","record":{"aliases":["GHSA-r9v2-gg2j-22q5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Payload CMS Stripe plugin","requires_auth":"low_privilege","summary":"Authenticated users can perform unintended Stripe operations via the REST proxy due to insufficient access control in the Payload CMS Stripe plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"payload","vendor":"payloadcms"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-749","name":"Exposed Dangerous Method or Function"}],"description":"Payload is a free and open source headless content management system. In @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user who can reach the enabled optional Stripe REST proxy can perform unintended Stripe operations. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Payload: Insufficient Access Control in Stripe REST Proxy","id":"CVE-2026-105848","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Payload: API key disclosure through ordinary document reads","id":"CVE-2026-105849"},"packages":[{"ecosystem":"npm","fixed":["3.90.0"],"introduced":["0"],"last_affected":[],"package":"@payloadcms/plugin-stripe","purl":null,"source":"GHSA-r9v2-gg2j-22q5"},{"ecosystem":"npm","fixed":["3.90.0"],"introduced":["0"],"last_affected":[],"package":"@payloadcms/plugin-stripe","purl":"pkg:npm/%40payloadcms/plugin-stripe","source":"GHSA-r9v2-gg2j-22q5"},{"ecosystem":"npm","fixed":["4.0.0-canary.34"],"introduced":["4.0.0-canary.0"],"last_affected":[],"package":"@payloadcms/plugin-stripe","purl":null,"source":"GHSA-r9v2-gg2j-22q5"},{"ecosystem":"npm","fixed":["4.0.0-canary.34"],"introduced":["4.0.0-canary.0"],"last_affected":[],"package":"@payloadcms/plugin-stripe","purl":"pkg:npm/%40payloadcms/plugin-stripe","source":"GHSA-r9v2-gg2j-22q5"}],"prev":{"headline":"Payload: Polymorphic join queries could disclose hidden fields","id":"CVE-2026-105847"},"products":["payload","plugin-stripe"],"published":"2026-10-06","related":[{"cvss_score":10,"headline":"Payload: RCE in Payload Form Builder","id":"CVE-2026-105857","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":9.8,"headline":"Payload: Unauthorized update to collection documents","id":"CVE-2026-105859","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":9.8,"headline":"Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters","id":"CVE-2026-25544","kev_date_added":null,"published":"2026-02-06"},{"cvss_score":9.8,"headline":"Unrestricted Upload of File with Dangerous Type in Payload","id":"CVE-2022-27952","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.3,"headline":"Payload: Field access control bypass on auth collections","id":"CVE-2026-105851","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":9.2,"headline":"Payload authentication token field handling issue","id":"CVE-2026-105863","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":9.1,"headline":"Payload has Unvalidated Input in Password Recovery Endpoints","id":"CVE-2026-34751","kev_date_added":null,"published":"2026-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-09","vendors":["@payloadcms","payloadcms"]},"summary":"Authenticated users can perform unintended Stripe operations via the REST proxy due to insufficient access control in the Payload CMS Stripe plugin.","url":"https://insights.sbomify.com/CVE-2026-105848/"}