# CVE-2026-105848: Payload: Insufficient Access Control in Stripe REST Proxy

> Authenticated users can perform unintended Stripe operations via the REST proxy due to insufficient access control in the Payload CMS Stripe plugin.

- **Severity:** Medium 6.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-r9v2-gg2j-22q5

## What is CVE-2026-105848?

CVE-2026-105848 is a medium-severity missing authorization vulnerability in @payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Payload is a free and open source headless content management system. In @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user who can reach the enabled optional Stripe REST proxy can perform unintended Stripe operations. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-862 (Missing Authorization), CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2026-105848?

4 open source packages ship an affected version, including @payloadcms/plugin-stripe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@payloadcms/plugin-stripe` | npm | All versions | 3.90.0 |
| `@payloadcms/plugin-stripe` | npm | All versions | 3.90.0 |
| `@payloadcms/plugin-stripe` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |
| `@payloadcms/plugin-stripe` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |

Products: Payloadcms Payload.

## How do I fix CVE-2026-105848?

Upgrade @payloadcms/plugin-stripe to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

## Is CVE-2026-105848 being exploited?

There is no known exploitation of CVE-2026-105848 in the wild and no public exploit code.

## Other vulnerabilities in @payloadcms payload

- [CVE-2026-105857](https://insights.sbomify.com/CVE-2026-105857/): Payload: RCE in Payload Form Builder (critical 10.0)
- [CVE-2026-105859](https://insights.sbomify.com/CVE-2026-105859/): Payload: Unauthorized update to collection documents (critical 9.8)
- [CVE-2026-25544](https://insights.sbomify.com/CVE-2026-25544/): Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters (critical 9.8)
- [CVE-2022-27952](https://insights.sbomify.com/CVE-2022-27952/): Unrestricted Upload of File with Dangerous Type in Payload (critical 9.8)
- [CVE-2026-105851](https://insights.sbomify.com/CVE-2026-105851/): Payload: Field access control bypass on auth collections (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105848 and fix it if it is affected.

What it is: CVE-2026-105848 is a medium-severity missing authorization vulnerability in @payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105848 in the wild and no public exploit code.

Affected packages and fixed versions:
- @payloadcms/plugin-stripe (npm): affected all versions; fixed in 3.90.0
- @payloadcms/plugin-stripe (npm): affected all versions; fixed in 3.90.0
- @payloadcms/plugin-stripe (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34
- @payloadcms/plugin-stripe (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105848/ (Markdown: https://insights.sbomify.com/CVE-2026-105848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105848
- OSV: https://osv.dev/vulnerability/CVE-2026-105848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105848/
Summaries are generated and may contain mistakes; the official description above is the record.
