CVE-2026-105850 Payload: Order confirmation validation issue in Payload Ecommerce

High 8.8 Published Updated

Attackers can process Stripe order confirmations multiple times, potentially altering order status or inventory, affecting Payload CMS Ecommerce plugin users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105850?

CVE-2026-105850 is a high-severity vulnerability in @payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In @payloadcms/plugin-ecommerce versions before 3.90.0 and canary versions before 4.0.0-canary.34, use of the Stripe payment adapter can allow a Stripe order confirmation to be processed more than once under certain conditions. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-837

Which versions are affected by CVE-2026-105850?

4 open source packages ship an affected version, including @payloadcms/plugin-ecommerce. It affects 1 product.

PackageAffectedFixed in
@payloadcms/plugin-ecommerce npmAll versions3.90.0
@payloadcms/plugin-ecommerce npmAll versions3.90.0
@payloadcms/plugin-ecommerce npmFrom 4.0.0-canary.04.0.0-canary.34
@payloadcms/plugin-ecommerce npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105850?

Upgrade @payloadcms/plugin-ecommerce to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Is CVE-2026-105850 being exploited?

There is no known exploitation of CVE-2026-105850 in the wild and no public exploit code.

Sources

Also known as GHSA-8r29-2mp2-pmrw.

Is CVE-2026-105850 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free