# CVE-2026-105850: Payload: Order confirmation validation issue in Payload Ecommerce

> Attackers can process Stripe order confirmations multiple times, potentially altering order status or inventory, affecting Payload CMS Ecommerce plugin users.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-8r29-2mp2-pmrw

## What is CVE-2026-105850?

CVE-2026-105850 is a high-severity vulnerability in @payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Payload is a free and open source headless content management system. In @payloadcms/plugin-ecommerce versions before 3.90.0 and canary versions before 4.0.0-canary.34, use of the Stripe payment adapter can allow a Stripe order confirmation to be processed more than once under certain conditions. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-837 (Improper Enforcement of a Single, Unique Action)

## Which versions are affected by CVE-2026-105850?

4 open source packages ship an affected version, including @payloadcms/plugin-ecommerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@payloadcms/plugin-ecommerce` | npm | All versions | 3.90.0 |
| `@payloadcms/plugin-ecommerce` | npm | All versions | 3.90.0 |
| `@payloadcms/plugin-ecommerce` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |
| `@payloadcms/plugin-ecommerce` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |

Products: Payloadcms Payload.

## How do I fix CVE-2026-105850?

Upgrade @payloadcms/plugin-ecommerce to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

## Is CVE-2026-105850 being exploited?

There is no known exploitation of CVE-2026-105850 in the wild and no public exploit code.

## Other vulnerabilities in @payloadcms payload

- [CVE-2026-105857](https://insights.sbomify.com/CVE-2026-105857/): Payload: RCE in Payload Form Builder (critical 10.0)
- [CVE-2026-105859](https://insights.sbomify.com/CVE-2026-105859/): Payload: Unauthorized update to collection documents (critical 9.8)
- [CVE-2026-25544](https://insights.sbomify.com/CVE-2026-25544/): Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters (critical 9.8)
- [CVE-2022-27952](https://insights.sbomify.com/CVE-2022-27952/): Unrestricted Upload of File with Dangerous Type in Payload (critical 9.8)
- [CVE-2026-105851](https://insights.sbomify.com/CVE-2026-105851/): Payload: Field access control bypass on auth collections (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105850 and fix it if it is affected.

What it is: CVE-2026-105850 is a high-severity vulnerability in @payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105850 in the wild and no public exploit code.

Affected packages and fixed versions:
- @payloadcms/plugin-ecommerce (npm): affected all versions; fixed in 3.90.0
- @payloadcms/plugin-ecommerce (npm): affected all versions; fixed in 3.90.0
- @payloadcms/plugin-ecommerce (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34
- @payloadcms/plugin-ecommerce (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105850/ (Markdown: https://insights.sbomify.com/CVE-2026-105850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105850
- OSV: https://osv.dev/vulnerability/CVE-2026-105850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105850/
Summaries are generated and may contain mistakes; the official description above is the record.
