CVE-2026-105855 Payload: Field-level password update restrictions were not enforced

High 7.6 Published Updated

Attackers can bypass field-level restrictions to update passwords in authentication collections, potentially taking over accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105855?

CVE-2026-105855 is a high-severity missing authorization vulnerability in payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, the server fails to enforce a field-level access.update restriction on the password field of an authentication collection. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-284

Which versions are affected by CVE-2026-105855?

4 open source packages ship an affected version, including payload. It affects 1 product.

PackageAffectedFixed in
payload npmAll versions3.90.0
payload npmAll versions3.90.0
payload npmFrom 4.0.0-canary.04.0.0-canary.34
payload npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105855?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-105855 being exploited?

There is no known exploitation of CVE-2026-105855 in the wild and no public exploit code.

Sources

Also known as GHSA-fx49-4h83-wjv9.

Is CVE-2026-105855 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free