CVE-2026-105857 Payload: RCE in Payload Form Builder

Critical 10.0 Published Updated

Attackers can execute arbitrary code on the server by submitting crafted forms in the Payload CMS Form Builder plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105857?

CVE-2026-105857 is a critical code injection vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In @payloadcms/plugin-form-builder versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can craft a form submission that executes code remotely on the server. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-94, CWE-1321

Which versions are affected by CVE-2026-105857?

4 open source packages ship an affected version, including @payloadcms/plugin-form-builder. It affects 1 product.

PackageAffectedFixed in
@payloadcms/plugin-form-builder npmAll versions3.90.0
@payloadcms/plugin-form-builder npmAll versions3.90.0
@payloadcms/plugin-form-builder npmFrom 4.0.0-canary.04.0.0-canary.34
@payloadcms/plugin-form-builder npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105857?

Upgrade @payloadcms/plugin-form-builder to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-105857 being exploited?

There is no known exploitation of CVE-2026-105857 in the wild and no public exploit code.

Sources

Also known as GHSA-r488-j9vj-wx3q.

Is CVE-2026-105857 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free