CVE-2026-105858 Payload: Remote Code Execution through first-register

High 8.1 Published Updated

Attackers can execute arbitrary code via the first-register operation in Payload CMS when local authentication is enabled and no user exists.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105858?

CVE-2026-105858 is a high-severity code injection vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, a crafted request to the public first-register operation can execute code remotely when local authentication is enabled and no initial user has been created. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-94, CWE-1321

Which versions are affected by CVE-2026-105858?

4 open source packages ship an affected version, including payload. It affects 1 product.

PackageAffectedFixed in
payload npmAll versions3.90.0
payload npmAll versions3.90.0
payload npmFrom 4.0.0-canary.04.0.0-canary.34
payload npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105858?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-105858 being exploited?

There is no known exploitation of CVE-2026-105858 in the wild and no public exploit code.

Sources

Also known as GHSA-97rh-rhh2-7vjv.

Is CVE-2026-105858 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free