CVE-2026-105859 Payload: Unauthorized update to collection documents

Critical 9.8 Published Updated

Attackers can modify collection documents without proper access control when orderable is enabled, requiring an upgrade to Payload CMS.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105859?

CVE-2026-105859 is a critical missing authorization vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can submit a request to a specific update endpoint that modifies collection documents without enforcing collection or field-level access control when orderable is enabled on a collection or join field. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-862, CWE-639

Which versions are affected by CVE-2026-105859?

4 open source packages ship an affected version, including payload. It affects 1 product.

PackageAffectedFixed in
payload npmAll versions3.90.0
payload npmAll versions3.90.0
payload npmFrom 4.0.0-canary.04.0.0-canary.34
payload npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105859?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-105859 being exploited?

There is no known exploitation of CVE-2026-105859 in the wild and no public exploit code.

Sources

Also known as GHSA-f7hx-52q9-hcrf.

Is CVE-2026-105859 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free