# CVE-2026-105861: Payload external upload trust validation issue

> Authenticated users can expose session data to unintended recipients via unverified external URL uploads in Payload CMS.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-pj5h-5q6c-3pfx

## What is CVE-2026-105861?

CVE-2026-105861 is a high-severity server-side request forgery vulnerability in payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Payload is a free and open source headless content management system. In versions after 3.0.0 and before 3.90.0, authenticated external URL-based upload retrieval can forward authentication data to a redirected destination that was not verified as trusted, potentially exposing a valid session to an unintended recipient. This issue is fixed in version 3.90.0.

Weakness: CWE-346 (Origin Validation Error), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-105861?

4 open source packages ship an affected version, including payload. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `payload` | npm | From 3.0.0 | 3.90.0 |
| `payload` | npm | From 3.0.0 | 3.90.0 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |

Products: Payloadcms Payload.

## How do I fix CVE-2026-105861?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

## Is CVE-2026-105861 being exploited?

There is no known exploitation of CVE-2026-105861 in the wild and no public exploit code.

## Other vulnerabilities in payloadcms payload

- [CVE-2026-105857](https://insights.sbomify.com/CVE-2026-105857/): Payload: RCE in Payload Form Builder (critical 10.0)
- [CVE-2026-105859](https://insights.sbomify.com/CVE-2026-105859/): Payload: Unauthorized update to collection documents (critical 9.8)
- [CVE-2026-25544](https://insights.sbomify.com/CVE-2026-25544/): Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters (critical 9.8)
- [CVE-2022-27952](https://insights.sbomify.com/CVE-2022-27952/): Unrestricted Upload of File with Dangerous Type in Payload (critical 9.8)
- [CVE-2026-105851](https://insights.sbomify.com/CVE-2026-105851/): Payload: Field access control bypass on auth collections (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105861 and fix it if it is affected.

What it is: CVE-2026-105861 is a high-severity server-side request forgery vulnerability in payloadcms payload, published on 6 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-105861 in the wild and no public exploit code.

Affected packages and fixed versions:
- payload (npm): affected from 3.0.0; fixed in 3.90.0
- payload (npm): affected from 3.0.0; fixed in 3.90.0
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105861/ (Markdown: https://insights.sbomify.com/CVE-2026-105861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105861
- OSV: https://osv.dev/vulnerability/CVE-2026-105861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105861/
Summaries are generated and may contain mistakes; the official description above is the record.
