CVE-2026-105866 Payload: Unauthenticated account-lockout denial of service

Medium 6.9 Published Updated

Unauthenticated attackers can lock out valid users by abusing the account lockout mechanism in Payload CMS, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-105866?

CVE-2026-105866 is a medium-severity denial of service vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, an unauthenticated attacker who knows an account email address or username can abuse the account lockout mechanism of a local-authentication collection to prevent that account from signing in. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-645, CWE-307

Which versions are affected by CVE-2026-105866?

4 open source packages ship an affected version, including payload. It affects 1 product.

PackageAffectedFixed in
payload npmAll versions3.90.0
payload npmAll versions3.90.0
payload npmFrom 4.0.0-canary.04.0.0-canary.34
payload npmFrom 4.0.0-canary.04.0.0-canary.34

Products include Payloadcms Payload.

How do I fix CVE-2026-105866?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-105866 being exploited?

There is no known exploitation of CVE-2026-105866 in the wild and no public exploit code.

Sources

Also known as GHSA-v5gf-vpjc-pc7w.

Is CVE-2026-105866 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free