# CVE-2026-105866: Payload: Unauthenticated account-lockout denial of service

> Unauthenticated attackers can lock out valid users by abusing the account lockout mechanism in Payload CMS, requiring an upgrade to fix.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-v5gf-vpjc-pc7w

## What is CVE-2026-105866?

CVE-2026-105866 is a medium-severity denial of service vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, an unauthenticated attacker who knows an account email address or username can abuse the account lockout mechanism of a local-authentication collection to prevent that account from signing in. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

Weakness: CWE-645 (Overly Restrictive Account Lockout Mechanism), CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-105866?

4 open source packages ship an affected version, including payload. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `payload` | npm | All versions | 3.90.0 |
| `payload` | npm | All versions | 3.90.0 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |
| `payload` | npm | From 4.0.0-canary.0 | 4.0.0-canary.34 |

Products: Payloadcms Payload.

## How do I fix CVE-2026-105866?

Upgrade payload to a fixed version for your release line: 3.90.0 or 4.0.0-canary.34.

## Is CVE-2026-105866 being exploited?

There is no known exploitation of CVE-2026-105866 in the wild and no public exploit code.

## Other vulnerabilities in payloadcms payload

- [CVE-2026-105857](https://insights.sbomify.com/CVE-2026-105857/): Payload: RCE in Payload Form Builder (critical 10.0)
- [CVE-2026-105859](https://insights.sbomify.com/CVE-2026-105859/): Payload: Unauthorized update to collection documents (critical 9.8)
- [CVE-2026-25544](https://insights.sbomify.com/CVE-2026-25544/): Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters (critical 9.8)
- [CVE-2022-27952](https://insights.sbomify.com/CVE-2022-27952/): Unrestricted Upload of File with Dangerous Type in Payload (critical 9.8)
- [CVE-2026-105851](https://insights.sbomify.com/CVE-2026-105851/): Payload: Field access control bypass on auth collections (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105866 and fix it if it is affected.

What it is: CVE-2026-105866 is a medium-severity denial of service vulnerability in payloadcms payload, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-105866 in the wild and no public exploit code.

Affected packages and fixed versions:
- payload (npm): affected all versions; fixed in 3.90.0
- payload (npm): affected all versions; fixed in 3.90.0
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34
- payload (npm): affected from 4.0.0-canary.0; fixed in 4.0.0-canary.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105866/ (Markdown: https://insights.sbomify.com/CVE-2026-105866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105866
- OSV: https://osv.dev/vulnerability/CVE-2026-105866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105866/
Summaries are generated and may contain mistakes; the official description above is the record.
