# CVE-2026-105922: vllm-project vLLM Penalty utils.py get_token_bin_counts_and_mask denial of service

> Remote attackers can cause a denial of service in vLLM by manipulating token bin counts, affecting the penalty handler component.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** GHSA-x9pq-jx6q-p3qv, MINI-3j3x-8jh7-8j2p, MINI-9g44-rffj-24w6, PYSEC-2026-4319

## What is CVE-2026-105922?

CVE-2026-105922 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security flaw has been discovered in vllm-project vLLM up to 0.31.0. This impacts the function get_token_bin_counts_and_mask of the file vllm/model_executor/layers/utils.py of the component Penalty Handler. Performing a manipulation results in denial of service. Remote exploitation of the attack is possible. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2026-105922?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.32.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-105922?

Upgrade vllm to 0.32.0 or later.

## Is CVE-2026-105922 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105922 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105922 and fix it if it is affected.

What it is: CVE-2026-105922 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-105922 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105922/ (Markdown: https://insights.sbomify.com/CVE-2026-105922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105922
- OSV: https://osv.dev/vulnerability/CVE-2026-105922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105922/
Summaries are generated and may contain mistakes; the official description above is the record.
