# CVE-2026-105930: Apache Pulsar: Improper Authorization of Function, Source and Sink Package URLs Allows Cross-Tenant Package Download


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-mqp8-6q9x-3qcp, MINI-9j56-r228-m8pq, MINI-cv7g-pw3g-qgx4, MINI-mpjm-6g64-qq2q, MINI-p4gr-xg9h-h9hj

## What is CVE-2026-105930?

CVE-2026-105930 is a medium-severity vulnerability in Apache Pulsar, published on 21 Oct 2026. 

### Official description

When package management is enabled, Pulsar Functions, Sources and Sinks can be registered or updated from a package stored in the Pulsar Packages Management Service by supplying a package URL. The Pulsar Functions worker authorized these requests only against the namespace in which the component was being registered or updated. It did not check whether the requesting user was permitted to access packages in the namespace that the package URL refers to, and it retrieved the package from the broker using the worker's own credentials. The permission check of the Packages Management Service was therefore applied to the worker's identity instead of the requesting user's. Package URLs of transform functions supplied when registering or updating a sink were handled in the same way.

An authenticated user who is permitted to register or update functions, sources or sinks in any namespace of their own tenant could use this to obtain the contents of a package stored in a namespace of another tenant, without having the packages permission on that namespace. The impact is limited to disclosure of package contents, which may include application code, business logic or embedded credentials. The issue does not allow packages to be modified or deleted and does not affect availability.

This issue only affects deployments that have authentication and authorization enabled and in which package management has been enabled: the broker setting enablePackagesManagement and, in current releases, the functions worker setting functionsWorkerEnablePackageManagement. Both settings are disabled by default.

This issue affects Apache Pulsar versions from 2.8.0 before 4.0.14, from 4.1.0 through 4.1.3, and from 4.2.0 before 4.2.5.

- 4.0.x version users should upgrade to at least 4.0.14.
- 4.1.x and 4.2.x version users should upgrade to at least 4.2.5.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

The currently supported Apache Pulsar release lines are 4.0.x and 5.0.x. The supported versions schedule is available at https://pulsar.apache.org/contribute/release-policy/.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-105930?


## How do I fix CVE-2026-105930?

Upgrade to a fixed version.

## Is CVE-2026-105930 being exploited?

There is no known exploitation of CVE-2026-105930 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-105930 and fix it if it is affected.

What it is: CVE-2026-105930 is a medium-severity vulnerability in Apache Pulsar, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-105930 in the wild and no public exploit code.

Affected product: Apache Pulsar. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-105930/ (Markdown: https://insights.sbomify.com/CVE-2026-105930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-105930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-105930
- OSV: https://osv.dev/vulnerability/CVE-2026-105930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-105930/
Summaries are generated and may contain mistakes; the official description above is the record.
